/[qspeakers]/README
ViewVC logotype

Diff of /README

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 111 by ben, Tue May 12 12:00:17 2015 UTC revision 112, Mon Apr 25 20:00:34 2016 UTC
# Line 1  Line 1 
1  Building QSpeakers:  Building QSpeakers:
2  * Pre requisites:  * Pre requisites:
3    Install Qt4 and the Qwt6, compiled against Qt4.    Install Qt5 and the Qwt6 library, compiled against Qt5.
4    Don't forget to install the header (.h) files too.    Don't forget to install the header (.h) files too.
5  * In short:    You also can install Qt4 and Qwt6 compiled against Qt4,
6      but you must take care of modifying the qspeakers.pro.
7    
8    * In short, for Qt5:
9      $ sudo apt-get install ^libqt5.* qt5-qmake qt5-default
10      $ cd qspeakers
11      $ qmake -config release && make && sudo make install
12    
13    * Or, for Qt4 (older debian/ubuntu):
14    $ sudo apt-get install libqt4-dev libqwt-dev qt4-qmake qt4-default    $ sudo apt-get install libqt4-dev libqwt-dev qt4-qmake qt4-default
15    $ cd qspeakers    $ cd qspeakers
16      $ replace -lqwt-qt5 with -lqwt, remove 'printingsupport' from "Qt +=" line
17    $ qmake-qt4 -config release && make && sudo make install    $ qmake-qt4 -config release && make && sudo make install
18    
19  Using QSpeakers:  Using QSpeakers:

Legend:
Removed from v.111  
changed lines
  Added in v.112

  ViewVC Help
Powered by ViewVC 1.1.26